VisualG – Exercícios para Treinar e Aprender

 

Exercícios de VisuAlG para Aprender Lógica

Veja no Wikipédia

Lista

Esta lista foi disponibilizada por Flaviano O. Silva, e as respostas dos exercícios, por Bruno Barbosa, no formato .alg que podem ser abertos, estudados e testados no VisualG. É uma excelente oportunidade para que você entenda como programar. A lista completa para você baixar pode ser vista clicando sobre os links nos nomes dos autores ou em Documents VisualG

Faça um algoritmo que receba dois números e exiba o resultado da sua soma.

 

Referências

Encontre mais

13 ideias sobre “VisualG – Exercícios para Treinar e Aprender”

  1. Boa tarde!
    Achei ótima a iniciativa. Parabéns, mas gostaria de melhorar um pouco do Exercício 5 sobre as media do Aluno. Segue:
    algoritmo “Media Aluno”
    // Função : colotar as 4 notas de um aluno e achar sua media
    // Autor : RRS
    // Data : 20/03/2015
    // Seção de Declarações
    var

    aluno:caracter
    notas: vetor[1..4] de real
    i: inteiro
    media,soma:real

    inicio
    LimpaTela
    media:=0
    soma:=0

    Escreval(“########## MEDIA ALUNOS ##########”)
    Escreval
    Escreva (“* Entre com o nome do aluno: ” )
    leia (aluno)

    Para i de 1 ate 4 faca
    Escreva(“* Digite a “,i,”o nota :”)
    leia(notas[i])
    FimPara

    Para i de 1 ate 4 faca
    soma:= (soma + notas[i])
    FimPara
    Escreval
    Escreval(“########## CALCULANDO A MEDIA ##########”)
    Escreval
    media := (Soma/4)
    Escreval(“A sua média foi de “, media:2:1)

    Se (media < 5.0) entao
    Escreval("Prezado ",aluno," infelizmente você está REPROVADO(A)!!" )
    Senao
    Se ((media = 5.0) ou (media = 7.0)Entao
    Escreval (“Prezado aluno você foi APROVADO(A) no curso. Parabéns!!”)
    Fimse

    FimAlgoritmo

  2. Olá estou com dificuldades para resolver esta questão,
    Crie um algoritmo para armazenar o valor 50 em uma variável W e o valor 65 em uma variável K. Crie uma variável chamada WK para armazenar a soma do valor de W com o de K. Escrever WK, W e K, individualmente na tela.
    Obs.: as variáveis W e K deverão ser informadas pelo usuário (comando Leia).

    fiz este código mas não sei como realizar a parte final que o exercicio pede,

    var

    w,k,wk: inteiro

    inicio

    escreval (“digite as letras w e k”)
    leia (w,k)

    w <- 50
    k <- 65
    wk <- w+k
    escreval (w)
    escreval (k)

    fimalgoritmo

    onde está os erros? obrigado!

  3. Exercício 4 acredito que está errado.
    Eu fiz da seguinte forma:
    Var
    nome:caractere
    salario,venda:real
    Inicio
    escreva (“Digite o seu nome: “)
    leia (nome)
    escreva (“Digite o seu salário fixo: “)
    leia (salario)
    escreva (“Quantidade de vendas em reais: “)
    leia (venda)
    salario<-(venda*0.15+salario)
    escreval (nome, ", você irá receber: ",salario)

    Fimalgoritmo

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *